Troubleshooting Cellular Connection on Freematics ONE+

Discussion about software developed by Freematics, including Freematics Builder and Freematics Emulator GUI
Post Reply
nunosan
Posts: 2
Joined: Thu Apr 27, 2023 8:50 am

Troubleshooting Cellular Connection on Freematics ONE+

Post by nunosan »

Hi,

I am having trouble connecting my Freematics ONE+ device to the cellular network. I am configuring the device using Platform IO and I can actually get it to transmit data to the Traccar Demo Server, using WIFI. But no luck on the cellular network as it keeps looping between "Searching" and "Activating" while printing the SIM Module 7070G and the IMEI. I have actually seen it go as far as printing the Network Operator name while I was testing the server configurations, but now that I have configured the server correctly I can not get it to go past the "Searching"/"Activating" loop. Please find below the sample of the monitor data:

CPU:160MHz FLASH:16MB
IRAM:329KB PSRAM:8MB
DEVICE ID:XXXXXX
TYPE:14
MEMS:ICM-42627
ACC BIAS:-0.03/0.01/1.01
GNSS:OK
OBD:NO
SD:7673 MB total, 0 MB used
File: /DATA/22.CSV
[CELL] Activating...
CELL:SIM7070G
IMEI:XXXXXX
[CELL] Searching...
[BUF] 3 samples | 30 bytes | 1/1024
[GPS] -25.974348 32.590939 1km/h SATS:7 Course:0 2023-04-24T15:25:18.600Z
[BUF] 17 samples | 146 bytes | 3/1024
[GPS] -25.974319 32.590916 0km/h SATS:7 Course:0 2023-04-24T15:25:21.500Z
[GPS] -25.974289 32.590923 0km/h SATS:7 Course:0 2023-04-24T15:25:24.400Z
[BUF] 39 samples | 318 bytes | 5/1024
[GPS] -25.974283 32.590923 1km/h SATS:8 Course:0 2023-04-24T15:25:27.300Z
[GPS] -25.974279 32.590912 0km/h SATS:7 Course:0 2023-04-24T15:25:30.200Z
[BUF] 61 samples | 490 bytes | 7/1024
[GPS] -25.974276 32.590904 0km/h SATS:7 Course:0 2023-04-24T15:25:33Z
[GPS] -25.974277 32.590893 1km/h SATS:8 Course:0 2023-04-24T15:25:35.900Z
[BUF] 83 samples | 662 bytes | 9/1024
[GPS] -25.974283 32.590881 1km/h SATS:7 Course:0 2023-04-24T15:25:38.800Z

+CGREG: 0,2

OK


+CGREG: 0,2

OK
[GPS] -25.974285 32.590874 0km/h SATS:7 Course:0 2023-04-24T15:25:41.700Z
[BUF] 105 samples | 834 bytes | 11/1024
[GPS] -25.974285 32.590870 0km/h SATS:8 Course:0 2023-04-24T15:25:44.600Z
[GPS] -25.974289 32.590862 0km/h SATS:9 Course:0 2023-04-24T15:25:47.500Z
[BUF] 127 samples | 1006 bytes | 13/1024
[GPS] -25.974289 32.590874 0km/h SATS:9 Course:0 2023-04-24T15:25:50.400Z
[FILE] 1KB
[GPS] -25.974300 32.590866 0km/h SATS:8 Course:0 2023-04-24T15:25:53.400Z
[BUF] 149 samples | 1178 bytes | 15/1024
[GPS] -25.974308 32.590858 0km/h SATS:8 Course:0 2023-04-24T15:25:56.300Z
[GPS] -25.974312 32.590851 0km/h SATS:8 Course:0 2023-04-24T15:25:59.200Z
[BUF] 171 samples | 1350 bytes | 17/1024
[CELL] Activating...
[GPS] -25.974316 32.590847 0km/h SATS:7 Course:0 2023-04-24T15:26:02.100Z
CELL:SIM7070G
IMEI:XXXXXXX
[CELL] Searching...
[GPS] -25.974319 32.590843 0km/h SATS:7 Course:0 2023-04-24T15:26:05Z
[BUF] 193 samples | 1522 bytes | 19/1024
[GPS] -25.974319 32.590836 0km/h SATS:8 Course:0 2023-04-24T15:26:07.900Z
[GPS] -25.974323 32.590828 0km/h SATS:8 Course:0 2023-04-24T15:26:10.700Z
[BUF] 215 samples | 1694 bytes | 21/1024
[GPS] -25.974323 32.590832 0km/h SATS:8 Course:0 2023-04-24T15:26:15.700Z
[BUF] 226 samples | 1780 bytes | 22/1024
[GPS] -25.974327 32.590828 0km/h SATS:8 Course:0 2023-04-24T15:26:20.600Z
[BUF] 237 samples | 1866 bytes | 23/1024
[GPS] -25.974327 32.590824 0km/h SATS:8 Course:0 2023-04-24T15:26:25.700Z
[BUF] 248 samples | 1952 bytes | 24/1024
[GPS] -25.974335 32.590839 0km/h SATS:9 Course:0 2023-04-24T15:26:30.700Z
[BUF] 259 samples | 2038 bytes | 25/1024

+CGREG: 0,2

OK


+CGREG: 0,2

OK

It keeps going on and on like this.

Thanks for the help in advance.
migie
Posts: 6
Joined: Fri Jun 16, 2023 10:11 pm

Re: Troubleshooting Cellular Connection on Freematics ONE+

Post by migie »

Hello,

Have you found a solution? I am having the same problem with my one+ Model B
stanley
Site Admin
Posts: 1034
Joined: Sat Mar 01, 2014 3:15 am

Re: Troubleshooting Cellular Connection on Freematics ONE+

Post by stanley »

Try leaving APN blank if using Freematics Builder or setting APN to "" in config.h
Electric
Posts: 1
Joined: Sat Jul 22, 2023 5:01 am

Re: Troubleshooting Cellular Connection on Freematics ONE+

Post by Electric »

I have exactly the same problem. Freematics ONE+ (Model B) keeps looping between "Searching" and "Activating".

I use Freematics Builder (firmware v5\teleloger) and with or without filling in the APN in the config.h or Builder: doesn't work. :cry:

I'm use an activated hologram.io SIM.
stanley
Site Admin
Posts: 1034
Joined: Sat Mar 01, 2014 3:15 am

Re: Troubleshooting Cellular Connection on Freematics ONE+

Post by stanley »

1. Try keeping device searching for a longer time (first time use of a new SIM card may take longer).
2. Try powering device from OBD instead of USB.
petroT78
Posts: 1
Joined: Fri Apr 19, 2024 9:26 pm

Re: Troubleshooting Cellular Connection on Freematics ONE+

Post by petroT78 »

Hello All.
Same problem here.
Searching/Activating all the time.
I tried 3 different operators in my area (Ukraine) with no luck.
Also tried empty APN, same result.
Power with USB / OBD same result.

model: freematics one+ Model B
Any suggestions? Thanks

UPD:
ok, so possible workaround solution might be :
enable WIFI, setup WIFI SSID to wrong name.
now it works
jesse99
Posts: 8
Joined: Tue Feb 20, 2024 6:21 pm

Re: Troubleshooting Cellular Connection on Freematics ONE+

Post by jesse99 »

Ensure that the module is receiving adequate power and placed in an area with good cellular signal reception. Poor signal strength can cause connection issues or delays in network registration. Capture detailed debugging logs from your PlatformIO environment to monitor AT command responses among us and module behavior during the connection process. Look for any errors or warnings that might indicate issues.
Post Reply